This project has moved and is read-only. For the latest updates, please go here.

Please help me with this error

May 24, 2011 at 6:37 PM

The tag 'DecimalUpDown' does not exist in XML namespace ''. Line 28 Position 22.

May 24, 2011 at 6:39 PM

Make sure the DLL isn't being blocked by your OS.  Right-click the WpfToolkit.Extended.dll and select properties.  Then click the "Unblock" button.  Let me know if that works.

May 24, 2011 at 6:54 PM

There is no Block or Unblock option in properties :(

May 24, 2011 at 6:56 PM

Make sure you are referencing the correct framework version.  For instance, if your application is .NET 4.0 make sure you are using the .NEt 4.0 libraries.  Also, make sure you are using the lastest version of ther toolkit

May 24, 2011 at 7:06 PM
Edited May 24, 2011 at 7:06 PM

I unblocked dll as well as checked the versions 


  1. Reference WPFToolkit.Extended.dll in your project
  2. Add a using statement ("using Microsoft.Windows.Controls;") to the top of .cs files
  3. Add a new xmlns (for example, xmlns:extToolkit="") to the top of XAML files
  4. Remember to use the namespace prefix (in the above example, <extToolkit: ...>) in the body of your XAML

used this procedure but error persist


error MC3074: The tag 'DoubleUpDown' does not exist in XML namespace ''. Line 28 Position 23.

May 24, 2011 at 7:08 PM

Since you unblocked it, try doing a clean and rebuild the solution.  Also, open a code behind file and see if you can delcare an instance of the control in code.

May 24, 2011 at 8:28 PM
Edited May 24, 2011 at 8:28 PM

i removed that error but now I have cannot  load file or assembly WPFToolkit.Extension publickeytoken ="342342432" 

May 24, 2011 at 8:41 PM

I don't know why you are having these problems.  Try deleting the reference and the DLL.  Then download the DLL again, unzip itm and unblock it.  Then add the reference to your porject.  Do a clean and rebuild.  If this doesn't work you can send me the project and dll and I will see if I can find the cause.

Jun 8, 2011 at 9:14 PM
Edited Jun 8, 2011 at 9:32 PM

I'm having a similar issue.

"The type 'extToolkit:DateTimePicker' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built."


<Window x:Class="testWpfApplication5.MainWindow"
        Title="MainWindow" Height="350" Width="525">
    <Grid x:Name="myGrid">
        <StackPanel x:Name="myStackPanel" />
        <extToolkit:DateTimePicker /><!--Intellisense does not recognize-->


It seems the dll that is provided in the download is actually  Where is  I downloaded the source, and the dll there is and it works fine.

Edit: I forgot to mention that with the dll in the download,, my project builds, and I can see the control, it's just WPF can't find any of the controls.  However, I am declare instances of the control (I'm using DateTimePicker) in the code behind without issue.

Jun 8, 2011 at 10:04 PM

The current source code is version  Make sure you are downloading the entire folder structure.  Open the solution that exists in the Main folder, not the releases folder. has not been released and therefore will not exist in the Releases folder.  Did you follow the steps provided in this post for unblicking the assembly?

Jun 8, 2011 at 10:16 PM

There was no button for unblocking.  The and seem to work fine.  I have the entire folder structure, I was just looking under Release, not Main.  I have no problem using the, however, could you either fix the under the download link or replace it with the


Jun 8, 2011 at 10:20 PM

I have no issues with the download link v1.4.0.2.  I was unable to duplicate this issue, nor have I had any mass reports of this issue which I would expect to have with nearly 7,200 downloads of v1.4.0.2.  Would you mind sending me a simple application with the DLL in question that has the issue, so that I can see what may be causing the issue?

Jun 8, 2011 at 10:32 PM

I believe you, I understand it's a strange error... I've tried the downloaded dll in two separate projects, got the same error, and even downloaded the dll twice before posting.  I am able to build with the dll, but the error doesn't get fixed on the build.  Intellisense can't find the controls, and the designer window can't display it.  What's strange is the first build reports no errors, it's only after the first one that the error shows up.  I have the sample project all zipped and ready to be sent.

Screenshot here:


Jun 8, 2011 at 10:45 PM
Edited Jun 9, 2011 at 2:10 PM

Can you email it to me at [EDIT: email removed]

Jun 8, 2011 at 11:08 PM

I’ve tried three times to email the zip file, but apparently our mail filter won’t let me send a zip file claiming it has a double extension.  Technology is wonderful isn’t it?  I’ll have to send it tomorrow, it’s 6pm here, so everyone else has gone home (like our email administrator) and I have no thumb drive with me to copy it to.

Thank you for your time and help on this issue.

Jun 9, 2011 at 2:07 PM

Well, I downloaded the dll at home, added it to a new project in my VS Express, and had no issues.  A quick google search on the error lead me to the answer.  When you had said to go to properties to unblock, I was looking at the properties of the assembly in Visual Studio, when I should have been looking at the properties of the dll in the directory.  And now that I've re-read your answer, "Make sure the DLL isn't being blocked by your OS" should have made it clear to me that I was looking in the wrong place in the properties.

So sure enough, I open the properties from Explorer, and there's the Unblock button.  No more issues.

Sorry for that, and thanks again for your time and help